blob: 2fb68469260972632c8727a29a9d3fd800991460 [file] [log] [blame]
Hans Leidekker5cfe6e92006-06-06 17:48:43 +02001@ stdcall DnsAcquireContextHandle_A(long ptr ptr)
2@ stdcall DnsAcquireContextHandle_UTF8(long ptr ptr)
3@ stdcall DnsAcquireContextHandle_W(long ptr ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +02004@ stub DnsAddRecordSet_A
5@ stub DnsAddRecordSet_UTF8
6@ stub DnsAddRecordSet_W
7@ stub DnsAllocateRecord
8@ stub DnsApiHeapReset
9@ stub DnsAsyncRegisterHostAddrs_A
10@ stub DnsAsyncRegisterHostAddrs_UTF8
11@ stub DnsAsyncRegisterHostAddrs_W
12@ stub DnsAsyncRegisterInit
13@ stub DnsAsyncRegisterTerm
14@ stub DnsCheckNameCollision_A
15@ stub DnsCheckNameCollision_UTF8
16@ stub DnsCheckNameCollision_W
17@ stub DnsCopyStringEx
18@ stub DnsCreateReverseNameStringForIpAddress
19@ stub DnsCreateStandardDnsNameCopy
20@ stub DnsCreateStringCopy
21@ stub DnsDhcpSrvRegisterHostName_W
22@ stub DnsDhcpSrvRegisterInit
23@ stub DnsDhcpSrvRegisterTerm
24@ stub DnsDisableAdapterDomainNameRegistration
25@ stub DnsDisableBNodeResolverThread
26@ stub DnsDisableDynamicRegistration
27@ stub DnsDowncaseDnsNameLabel
28@ stub DnsEnableAdapterDomainNameRegistration
29@ stub DnsEnableBNodeResolverThread
30@ stub DnsEnableDynamicRegistration
Hans Leidekker5cfe6e92006-06-06 17:48:43 +020031@ stdcall DnsExtractRecordsFromMessage_UTF8(ptr long ptr)
32@ stdcall DnsExtractRecordsFromMessage_W(ptr long ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020033@ stub DnsFindAuthoritativeZone
Austin English5b21d902009-08-25 15:22:47 -050034@ stdcall DnsFlushResolverCache()
Hans Leidekker6b1dded2006-04-09 18:35:43 +020035@ stub DnsFlushResolverCacheEntry_A
36@ stub DnsFlushResolverCacheEntry_UTF8
37@ stub DnsFlushResolverCacheEntry_W
Hans Leidekker8a29a4a2011-08-24 10:23:04 +020038@ stdcall DnsFree(ptr long)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020039@ stub DnsFreeAdapterInformation
40@ stub DnsFreeNetworkInformation
41@ stub DnsFreeSearchInformation
42@ stub DnsGetBufferLengthForStringCopy
43@ stub DnsGetCacheDataTable
44@ stub DnsGetDnsServerList
45@ stub DnsGetDomainName
46@ stub DnsGetHostName_A
47@ stub DnsGetHostName_UTF8
48@ stub DnsGetHostName_W
49@ stub DnsGetIpAddressInfoList
50@ stub DnsGetIpAddressList
51@ stub DnsGetLastServerUpdateIP
52@ stub DnsGetMaxNumberOfAddressesToRegister
53@ stub DnsGetNetworkInformation
54@ stub DnsGetPrimaryDomainName_A
55@ stub DnsGetPrimaryDomainName_UTF8
56@ stub DnsGetPrimaryDomainName_W
57@ stub DnsGetSearchInformation
58@ stub DnsIpv6AddressToString
59@ stub DnsIpv6StringToAddress
60@ stub DnsIsAdapterDomainNameRegistrationEnabled
61@ stub DnsIsAMailboxType
62@ stub DnsIsDynamicRegistrationEnabled
63@ stub DnsIsStatusRcode
64@ stub DnsIsStringCountValidForTextType
65@ stub DnsMapRcodeToStatus
66@ stub DnsModifyRecordSet_A
67@ stub DnsModifyRecordSet_UTF8
68@ stub DnsModifyRecordSet_W
Hans Leidekker5cfe6e92006-06-06 17:48:43 +020069@ stdcall DnsModifyRecordsInSet_A(ptr ptr long ptr ptr ptr)
70@ stdcall DnsModifyRecordsInSet_UTF8(ptr ptr long ptr ptr ptr)
71@ stdcall DnsModifyRecordsInSet_W(ptr ptr long ptr ptr ptr)
Hans Leidekker486e3b32006-04-09 18:35:48 +020072@ stdcall DnsNameCompare_A(str str)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020073@ stub DnsNameCompareEx_A
74@ stub DnsNameCompareEx_UTF8
75@ stub DnsNameCompareEx_W
Hans Leidekker486e3b32006-04-09 18:35:48 +020076@ stdcall DnsNameCompare_W(wstr wstr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020077@ stub DnsNameCopy
78@ stub DnsNameCopyAllocate
79@ stub DnsNotifyResolver
Hans Leidekker59317392006-05-29 12:47:31 +020080@ stdcall DnsQuery_A(str long long ptr ptr ptr)
Hans Leidekkerda1d7242006-05-09 10:47:06 +020081@ stdcall DnsQueryConfig(long long wstr ptr ptr ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020082@ stub DnsQueryEx
Hans Leidekker59317392006-05-29 12:47:31 +020083@ stdcall DnsQuery_UTF8(str long long ptr ptr ptr)
84@ stdcall DnsQuery_W(wstr long long ptr ptr ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020085@ stub DnsRecordBuild_UTF8
86@ stub DnsRecordBuild_W
Hans Leidekkerc6c1e052006-05-01 16:28:56 +020087@ stdcall DnsRecordCompare(ptr ptr)
Hans Leidekker686bcd22006-05-01 16:29:14 +020088@ stdcall DnsRecordCopyEx(ptr long long)
89@ stdcall DnsRecordListFree(ptr long)
Hans Leidekkerefe9ced2006-05-08 16:39:23 +020090@ stdcall DnsRecordSetCompare(ptr ptr ptr ptr)
Hans Leidekker686bcd22006-05-01 16:29:14 +020091@ stdcall DnsRecordSetCopyEx(ptr long long)
Hans Leidekker0c0d1902006-09-13 14:36:33 +020092@ stdcall DnsRecordSetDetach(ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020093@ stub DnsRecordStringForType
94@ stub DnsRecordStringForWritableType
95@ stub DnsRecordTypeForName
96@ stub DnsRelationalCompare_UTF8
97@ stub DnsRelationalCompare_W
Hans Leidekker5cfe6e92006-06-06 17:48:43 +020098@ stdcall DnsReleaseContextHandle(ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +020099@ stub DnsRemoveRegistrations
Hans Leidekker5cfe6e92006-06-06 17:48:43 +0200100@ stdcall DnsReplaceRecordSetA(ptr long ptr ptr ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +0200101@ stub DnsReplaceRecordSet_A
Hans Leidekker5cfe6e92006-06-06 17:48:43 +0200102@ stdcall DnsReplaceRecordSetUTF8(ptr long ptr ptr ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +0200103@ stub DnsReplaceRecordSet_UTF8
Hans Leidekker5cfe6e92006-06-06 17:48:43 +0200104@ stdcall DnsReplaceRecordSetW(ptr long ptr ptr ptr)
Hans Leidekker6b1dded2006-04-09 18:35:43 +0200105@ stub DnsReplaceRecordSet_W
106@ stub DnsServiceNotificationDeregister_A
107@ stub DnsServiceNotificationDeregister_UTF8
108@ stub DnsServiceNotificationDeregister_W
109@ stub DnsServiceNotificationRegister_A
110@ stub DnsServiceNotificationRegister_UTF8
111@ stub DnsServiceNotificationRegister_W
112@ stub DnsSetMaxNumberOfAddressesToRegister
113@ stub DnsStatusString
114@ stub DnsStringCopyAllocateEx
115@ stub DnsUnicodeToUtf8
116@ stub DnsUpdate
117@ stub DnsUpdateTest_A
118@ stub DnsUpdateTest_UTF8
119@ stub DnsUpdateTest_W
120@ stub DnsUtf8ToUnicode
Hans Leidekkerb2c4b2c2006-05-02 16:37:18 +0200121@ stdcall DnsValidateName_A(str long)
122@ stdcall DnsValidateName_UTF8(str long)
123@ stdcall DnsValidateName_W(wstr long)
Hans Leidekker6b1dded2006-04-09 18:35:43 +0200124@ stub DnsValidateUtf8Byte
125@ stub DnsWinsRecordFlagForString
126@ stub DnsWinsRecordFlagString
Hans Leidekkera3a2f062006-10-20 16:13:52 +0200127@ stdcall DnsWriteQuestionToBuffer_UTF8(ptr ptr str long long long)
128@ stdcall DnsWriteQuestionToBuffer_W(ptr ptr wstr long long long)
Hans Leidekker6b1dded2006-04-09 18:35:43 +0200129@ stub DnsWriteReverseNameStringForIpAddress
130@ stub GetCurrentTimeInSeconds