blob: dba31986b010d8dff149ce15f681282f16b57044 [file] [log] [blame]
Alexandre Julliard7cae5582002-06-01 02:55:48 +00001# Functions exported by the Win95 shell32.dll
2# (these need to have these exact ordinals, for some
Alexandre Julliard642d3131998-07-12 19:29:36 +00003# win95 and winNT dlls import shell32.dll by ordinal)
4# This list was updated to dll version 4.72
Alexandre Julliardd37eb361997-07-20 16:23:21 +00005
Alexandre Julliard114a31a2003-03-20 03:53:12 +00006 2 stdcall SHChangeNotifyRegister(long long long long long long)
7 4 stdcall SHChangeNotifyDeregister (long)
8 5 stdcall SHChangeNotifyUpdateEntryList (long long long long)
Alexandre Julliard829fe321998-07-26 14:27:39 +00009 9 stub PifMgr_OpenProperties@16
10 10 stub PifMgr_GetProperties@20
11 11 stub PifMgr_SetProperties@20
Alexandre Julliard829fe321998-07-26 14:27:39 +000012 13 stub PifMgr_CloseProperties@8
Alexandre Julliard114a31a2003-03-20 03:53:12 +000013 15 stdcall ILGetDisplayName(ptr ptr)
14 16 stdcall ILFindLastID(ptr)
15 17 stdcall ILRemoveLastID(ptr)
16 18 stdcall ILClone(ptr)
17 19 stdcall ILCloneFirst (ptr)
18 20 stdcall ILGlobalClone (ptr)
19 21 stdcall ILIsEqual (ptr ptr)
20 23 stdcall ILIsParent (long long long)
21 24 stdcall ILFindChild (long long)
22 25 stdcall ILCombine(ptr ptr)
23 26 stdcall ILLoadFromStream (ptr ptr)
24 27 stdcall ILSaveToStream(ptr ptr)
Juergen Schmieddd153f11999-03-13 17:10:36 +000025 28 stdcall SHILCreateFromPath (long long long) SHILCreateFromPathAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000026 29 stdcall PathIsRoot(ptr) PathIsRootAW
Juergen Schmied6b266db2000-04-28 20:19:35 +000027 30 stdcall PathBuildRoot(ptr long) PathBuildRootAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000028 31 stdcall PathFindExtension(ptr) PathFindExtensionAW
29 32 stdcall PathAddBackslash(ptr) PathAddBackslashAW
Juergen Schmied6b266db2000-04-28 20:19:35 +000030 33 stdcall PathRemoveBlanks(ptr) PathRemoveBlanksAW
31 34 stdcall PathFindFileName(ptr) PathFindFileNameAW
32 35 stdcall PathRemoveFileSpec(ptr) PathRemoveFileSpecAW
33 36 stdcall PathAppend(ptr ptr) PathAppendAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000034 37 stdcall PathCombine(ptr ptr ptr) PathCombineAW
Juergen Schmied6b266db2000-04-28 20:19:35 +000035 38 stdcall PathStripPath(ptr)PathStripPathAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000036 39 stdcall PathIsUNC (ptr) PathIsUNCAW
37 40 stdcall PathIsRelative (ptr) PathIsRelativeAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000038 43 stdcall PathIsExe (ptr) PathIsExeAW
Juergen Schmied6b266db2000-04-28 20:19:35 +000039 45 stdcall PathFileExists(ptr) PathFileExistsAW
40 46 stdcall PathMatchSpec (ptr ptr) PathMatchSpecAW
41 47 stdcall PathMakeUniqueName (ptr long ptr ptr ptr)PathMakeUniqueNameAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000042 48 stdcall PathSetDlgItemPath (long long ptr) PathSetDlgItemPathAW
43 49 stdcall PathQualify (ptr) PathQualifyAW
Juergen Schmied6b266db2000-04-28 20:19:35 +000044 50 stdcall PathStripToRoot (ptr) PathStripToRootAW
45 51 stdcall PathResolve(str long long) PathResolveAW
Alexandre Julliarda3960291999-02-26 11:11:13 +000046 52 stdcall PathGetArgs(str) PathGetArgsAW
Juergen Schmied37fe75b1999-07-10 11:54:17 +000047 53 stdcall DoEnvironmentSubst (long long) DoEnvironmentSubstAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +000048 54 stdcall DragAcceptFiles(long long)
Alexandre Julliarda3960291999-02-26 11:11:13 +000049 55 stdcall PathQuoteSpaces (ptr) PathQuoteSpacesAW
50 56 stdcall PathUnquoteSpaces(str) PathUnquoteSpacesAW
Juergen Schmied6b266db2000-04-28 20:19:35 +000051 57 stdcall PathGetDriveNumber (str) PathGetDriveNumberAW
52 58 stdcall ParseField(str long ptr long) ParseFieldAW
Juergen Schmied72b76d11998-11-15 13:28:00 +000053 59 stub RestartDialog@12
Alexandre Julliard114a31a2003-03-20 03:53:12 +000054 60 stdcall ExitWindowsDialog(long)
55 61 stdcall RunFileDlg(long long long str str long)
56 62 stdcall PickIconDlg(long long long long)
57 63 stdcall GetFileNameFromBrowse(long long long long str str str)
58 64 stdcall DriveType (long)
Alexandre Julliard642d3131998-07-12 19:29:36 +000059 65 stub InvalidateDriveType
Alexandre Julliard114a31a2003-03-20 03:53:12 +000060 66 stdcall IsNetDrive(long)
61 67 stdcall Shell_MergeMenus (long long long long long long)
62 68 stdcall SHGetSetSettings(ptr long long)
Alexandre Julliard642d3131998-07-12 19:29:36 +000063 69 stub SHGetNetResource
Alexandre Julliard114a31a2003-03-20 03:53:12 +000064 70 stdcall SHCreateDefClassObject(long long long long long)
65 71 stdcall Shell_GetImageList(ptr ptr)
Juergen Schmied6d17c612000-01-04 00:33:56 +000066 72 stdcall Shell_GetCachedImageIndex(ptr ptr long) Shell_GetCachedImageIndexAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +000067 73 stdcall SHShellFolderView_Message(long long long)
68 74 stdcall SHCreateStdEnumFmtEtc(long ptr ptr)
Juergen Schmied6b266db2000-04-28 20:19:35 +000069 75 stdcall PathYetAnotherMakeUniqueName(ptr ptr ptr ptr) PathYetAnotherMakeUniqueNameA
Alexandre Julliard642d3131998-07-12 19:29:36 +000070 76 stub DragQueryInfo
Alexandre Julliard114a31a2003-03-20 03:53:12 +000071 77 stdcall SHMapPIDLToSystemImageListIndex(ptr ptr ptr)
Juergen Schmied565b2e01999-07-25 12:26:05 +000072 78 stdcall OleStrToStrN(str long wstr long) OleStrToStrNAW
Juergen Schmied37fe75b1999-07-10 11:54:17 +000073 79 stdcall StrToOleStrN(wstr long str long) StrToOleStrNAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +000074 80 stdcall DragFinish(long)
Alexandre Julliarda3960291999-02-26 11:11:13 +000075 81 stdcall DragQueryFile(long long ptr long) DragQueryFileA
Alexandre Julliard114a31a2003-03-20 03:53:12 +000076 82 stdcall DragQueryFileA(long long ptr long)
77 83 stdcall CIDLData_CreateFromIDArray(ptr long ptr ptr)
Alexandre Julliard642d3131998-07-12 19:29:36 +000078 84 stub SHIsBadInterfacePtr
Alexandre Julliarda9c51cb2003-03-17 00:17:00 +000079 85 stdcall OpenRegStream(long str str long) shlwapi.SHOpenRegStreamA
Alexandre Julliard114a31a2003-03-20 03:53:12 +000080 86 stdcall SHRegisterDragDrop(long ptr)
81 87 stdcall SHRevokeDragDrop(long)
82 88 stdcall SHDoDragDrop(long ptr ptr long ptr)
83 89 stdcall SHCloneSpecialIDList(long long long)
Alexandre Julliard642d3131998-07-12 19:29:36 +000084 90 stub SHFindFiles
85 91 stub SHFindComputer
Juergen Schmied6b266db2000-04-28 20:19:35 +000086 92 stdcall PathGetShortPath (ptr) PathGetShortPathAW
Alexandre Julliard642d3131998-07-12 19:29:36 +000087 93 stub Win32CreateDirectory
88 94 stub Win32RemoveDirectory
Alexandre Julliard114a31a2003-03-20 03:53:12 +000089 95 stdcall SHLogILFromFSIL (ptr)
Rolf Kalbermatter49e1b692003-01-21 19:36:24 +000090 96 stdcall StrRetToStrN (ptr long ptr ptr) StrRetToStrNAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +000091 97 stdcall SHWaitForFileToOpen (long long long)
92 98 stdcall SHGetRealIDL (long long long)
93 99 stdcall SetAppStartingCursor (long long)
94 100 stdcall SHRestricted(long)
95 102 stdcall SHCoCreateInstance(ptr ptr long ptr ptr)
96 103 stdcall SignalFileOpen(long)
97 104 stdcall FileMenu_DeleteAllItems(long)
98 105 stdcall FileMenu_DrawItem(long ptr)
99 106 stdcall FileMenu_FindSubMenuByPidl(long ptr)
100 107 stdcall FileMenu_GetLastSelectedItemPidls(long ptr ptr)
101 108 stdcall FileMenu_HandleMenuChar(long long)
102 109 stdcall FileMenu_InitMenuPopup (long)
103 110 stdcall FileMenu_InsertUsingPidl (long long ptr long long ptr)
104 111 stdcall FileMenu_Invalidate (long)
105 112 stdcall FileMenu_MeasureItem(long ptr)
106 113 stdcall FileMenu_ReplaceUsingPidl (long long ptr long ptr)
107 114 stdcall FileMenu_Create (long long long long long)
Juergen Schmied7c6cc491999-04-01 10:24:21 +0000108 115 stdcall FileMenu_AppendItem (long ptr long long long long) FileMenu_AppendItemAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000109 116 stdcall FileMenu_TrackPopupMenuEx (long long long long long long)
110 117 stdcall FileMenu_DeleteItemByCmd(long long)
111 118 stdcall FileMenu_Destroy (long)
Alexandre Julliarda3960291999-02-26 11:11:13 +0000112 119 stdcall IsLFNDrive(str) IsLFNDriveA
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000113 120 stdcall FileMenu_AbortInitMenu ()
114 121 stdcall SHFlushClipboard ()
115 122 stdcall RunDLL_CallEntry16 (long long long long long) #name wrong?
116 123 stdcall SHFreeUnusedLibraries ()
117 124 stdcall FileMenu_AppendFilesForPidl(long ptr long)
118 125 stdcall FileMenu_AddFilesForPidl(long long long ptr long long ptr)
119 126 stdcall SHOutOfMemoryMessageBox (long long long)
120 127 stdcall SHWinHelp (long long long long)
Alexandre Julliarde658d821997-11-30 17:45:40 +0000121 128 stdcall DllGetClassObject(long long ptr) SHELL32_DllGetClassObject
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000122 129 stdcall DAD_AutoScroll(long ptr ptr)
123 130 stdcall DAD_DragEnter(long)
124 131 stdcall DAD_DragEnterEx(long long long)
125 132 stdcall DAD_DragLeave()
126 133 stdcall DragQueryFileW(long long ptr long)
127 134 stdcall DAD_DragMove(long long)
128 135 stdcall DragQueryPoint(long ptr)
129 136 stdcall DAD_SetDragImage(long long)
130 137 stdcall DAD_ShowDragImage (long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000131 139 stub Desktop_UpdateBriefcaseOnEvent
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000132 140 stdcall FileMenu_DeleteItemByIndex(long long)
133 141 stdcall FileMenu_DeleteItemByFirstID(long long)
134 142 stdcall FileMenu_DeleteSeparator(long)
135 143 stdcall FileMenu_EnableItemByCmd(long long long)
136 144 stdcall FileMenu_GetItemExtent (long long)
Alexandre Julliarda3960291999-02-26 11:11:13 +0000137 145 stdcall PathFindOnPath (ptr ptr) PathFindOnPathAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000138 146 stdcall RLBuildListOfPaths()
Juergen Schmied565b2e01999-07-25 12:26:05 +0000139 147 stdcall SHCLSIDFromString(long long) SHCLSIDFromStringAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000140 149 stdcall SHFind_InitMenuPopup(long long long long)
141 151 stdcall SHLoadOLE (long)
142 152 stdcall ILGetSize(ptr)
143 153 stdcall ILGetNext(ptr)
144 154 stdcall ILAppend (long long long)
145 155 stdcall ILFree (ptr)
146 156 stdcall ILGlobalFree (ptr)
Juergen Schmieddd153f11999-03-13 17:10:36 +0000147 157 stdcall ILCreateFromPath (ptr) ILCreateFromPathAW
Uwe Bonnes97ac9612001-08-15 23:20:21 +0000148 158 stdcall PathGetExtension(str long long) PathGetExtensionAW
Juergen Schmied2ff02942000-02-26 18:46:03 +0000149 159 stdcall PathIsDirectory(ptr)PathIsDirectoryAW
Alexandre Julliard642d3131998-07-12 19:29:36 +0000150 160 stub SHNetConnectionDialog
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000151 161 stdcall SHRunControlPanel (long long)
Alexandre Julliarda3960291999-02-26 11:11:13 +0000152 162 stdcall SHSimpleIDListFromPath (ptr) SHSimpleIDListFromPathAW
Juergen Schmied37fe75b1999-07-10 11:54:17 +0000153 163 stdcall StrToOleStr (wstr str) StrToOleStrAW
Rolf Kalbermatterd11efe82003-02-01 00:41:30 +0000154 164 stdcall Win32DeleteFile(str) Win32DeleteFileAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000155 165 stdcall SHCreateDirectory(long ptr)
156 166 stdcall CallCPLEntry16(long long long long long long)
157 167 stdcall SHAddFromPropSheetExtArray(long long long)
158 168 stdcall SHCreatePropSheetExtArray(long str long)
159 169 stdcall SHDestroyPropSheetExtArray(long)
160 170 stdcall SHReplaceFromPropSheetExtArray(long long long long)
Juergen Schmiedeac255c1999-08-15 14:31:36 +0000161 171 stdcall PathCleanupSpec(ptr ptr) PathCleanupSpecAW
Alexandre Julliard642d3131998-07-12 19:29:36 +0000162 172 stub SHCreateLinks
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000163 173 stdcall SHValidateUNC(long long long)
164 174 stdcall SHCreateShellFolderViewEx (ptr ptr)
Juergen Schmied565b2e01999-07-25 12:26:05 +0000165 175 stdcall SHGetSpecialFolderPath(long long long long) SHGetSpecialFolderPathAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000166 176 stdcall SHSetInstanceExplorer (long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000167 177 stub DAD_SetDragImageFromListView
168 178 stub SHObjectProperties
169 179 stub SHGetNewLinkInfoA
170 180 stub SHGetNewLinkInfoW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000171 181 stdcall RegisterShellHook(long long)
172 182 varargs ShellMessageBoxW(long long long str long)
173 183 varargs ShellMessageBoxA(long long long str long)
174 184 stdcall ArrangeWindows(long long long long long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000175 185 stub SHHandleDiskFull
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000176 195 stdcall SHFree(ptr)
177 196 stdcall SHAlloc(long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000178 197 stub SHGlobalDefect
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000179 198 stdcall SHAbortInvokeCommand ()
Alexandre Julliard642d3131998-07-12 19:29:36 +0000180 199 stub SHGetFileIcon
181 200 stub SHLocalAlloc
182 201 stub SHLocalFree
183 202 stub SHLocalReAlloc
184 203 stub AddCommasW
185 204 stub ShortSizeFormatW
186 205 stub Printer_LoadIconsW
187 206 stub Link_AddExtraDataSection
188 207 stub Link_ReadExtraDataSection
189 208 stub Link_RemoveExtraDataSection
190 209 stub Int64ToString
191 210 stub LargeIntegerToString
192 211 stub Printers_GetPidl
193 212 stub Printer_AddPrinterPropPages
194 213 stub Printers_RegisterWindowW
195 214 stub Printers_UnregisterWindow
196 215 stub SHStartNetConnectionDialog@12
Francois Gouget8a5de1c2000-12-14 19:25:13 +0000197 243 stdcall @(long long) shell32_243
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000198 244 stdcall SHInitRestricted(ptr ptr)
199 247 stdcall SHGetDataFromIDListA (ptr ptr long ptr long)
200 248 stdcall SHGetDataFromIDListW (ptr ptr long ptr long)
Juergen Schmied6b266db2000-04-28 20:19:35 +0000201 249 stdcall PathParseIconLocation (ptr) PathParseIconLocationAW
202 250 stdcall PathRemoveExtension (ptr) PathRemoveExtensionAW
203 251 stdcall PathRemoveArgs (ptr) PathRemoveArgsAW
Alexandre Julliard642d3131998-07-12 19:29:36 +0000204 271 stub SheChangeDirA
205 272 stub SheChangeDirExA
206 273 stub SheChangeDirExW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000207 274 stdcall SheChangeDirW(wstr)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000208 275 stub SheConvertPathW
209 276 stub SheFullPathA
210 277 stub SheFullPathW
211 278 stub SheGetCurDrive
Juergen Schmiede8d281d1998-10-24 09:22:57 +0000212 279 stub SheGetDirA@8
213 280 stub SheGetDirExW@12
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000214 281 stdcall SheGetDirW (long long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000215 282 stub SheGetPathOffsetW
216 283 stub SheRemoveQuotesA
217 284 stub SheRemoveQuotesW
218 285 stub SheSetCurDrive
219 286 stub SheShortenPathA
220 287 stub SheShortenPathW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000221 288 stdcall ShellAboutA(long str str long)
222 289 stdcall ShellAboutW(long wstr wstr long)
223 290 stdcall ShellExecuteA(long str str str str long)
Alexandre Julliarda3960291999-02-26 11:11:13 +0000224 291 stdcall ShellExecuteEx (long) ShellExecuteExAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000225 292 stdcall ShellExecuteExA (long)
226 293 stdcall ShellExecuteExW (long)
227 294 stdcall ShellExecuteW (long wstr wstr wstr wstr long)
Peter Hunnisett565b0082000-09-19 02:43:00 +0000228 296 stdcall Shell_NotifyIcon(long ptr) Shell_NotifyIconA
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000229 297 stdcall Shell_NotifyIconA(long ptr)
230 298 stdcall Shell_NotifyIconW(long ptr)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000231 299 stub Shl1632_ThunkData32
232 300 stub Shl3216_ThunkData32
Alexandre Julliarda9c51cb2003-03-17 00:17:00 +0000233 301 stdcall StrChrA(str long) shlwapi.StrChrA
234 302 stdcall StrChrIA(str long) shlwapi.StrChrIA
235 303 stdcall StrChrIW(wstr long) shlwapi.StrChrIW
236 304 stdcall StrChrW(wstr long) shlwapi.StrChrW
237 305 stdcall StrCmpNA(str str long) shlwapi.StrCmpNA
238 306 stdcall StrCmpNIA(str str long) shlwapi.StrCmpNIA
239 307 stdcall StrCmpNIW(wstr wstr long) shlwapi.StrCmpNIW
240 308 stdcall StrCmpNW(wstr wstr long) shlwapi.StrCmpNW
Juergen Schmied2ff02942000-02-26 18:46:03 +0000241 309 stdcall StrCpyNA (ptr str long) lstrcpynA
Alexandre Julliarda9c51cb2003-03-17 00:17:00 +0000242 310 stdcall StrCpyNW(wstr wstr long) shlwapi.StrCpyNW
243 311 stdcall StrNCmpA(str str long) shlwapi.StrCmpNA
244 312 stdcall StrNCmpIA(str str long) shlwapi.StrCmpNIA
245 313 stdcall StrNCmpIW(wstr wstr long) shlwapi.StrCmpNIW
246 314 stdcall StrNCmpW(wstr wstr long) shlwapi.StrCmpNW
Juergen Schmied2ff02942000-02-26 18:46:03 +0000247 315 stdcall StrNCpyA (ptr str long) lstrcpynA
Alexandre Julliarda9c51cb2003-03-17 00:17:00 +0000248 316 stdcall StrNCpyW(wstr wstr long) shlwapi.StrCpyNW
249 317 stdcall StrRChrA(str str long) shlwapi.StrRChrA
250 318 stdcall StrRChrIA(str str long) shlwapi.StrRChrIA
251 319 stdcall StrRChrIW(str str long) shlwapi.StrRChrIW
252 320 stdcall StrRChrW(wstr wstr long) shlwapi.StrRChrW
Juergen Schmied2ff02942000-02-26 18:46:03 +0000253 321 stub StrRStrA
Alexandre Julliarda9c51cb2003-03-17 00:17:00 +0000254 322 stdcall StrRStrIA(str str str) shlwapi.StrRStrIA
255 323 stdcall StrRStrIW(wstr wstr wstr) shlwapi.StrRStrIW
Juergen Schmied2ff02942000-02-26 18:46:03 +0000256 324 stub StrRStrW
Alexandre Julliarda9c51cb2003-03-17 00:17:00 +0000257 325 stdcall StrStrA(str str) shlwapi.StrStrA
258 326 stdcall StrStrIA(str str) shlwapi.StrStrIA
259 327 stdcall StrStrIW(wstr wstr) shlwapi.StrStrIW
260 328 stdcall StrStrW(wstr wstr) shlwapi.StrStrW
Alexandre Julliard642d3131998-07-12 19:29:36 +0000261
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000262 505 stdcall SHRegCloseKey (long)
263 506 stdcall SHRegOpenKeyA (long str long)
264 507 stdcall SHRegOpenKeyW (long wstr long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000265 508 stub SHRegQueryValueA@16
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000266 509 stdcall SHRegQueryValueExA(long str ptr ptr ptr ptr)
267 510 stdcall SHRegQueryValueW (long long long long)
268 511 stdcall SHRegQueryValueExW (long wstr ptr ptr ptr ptr)
269 512 stdcall SHRegDeleteKeyW (long wstr)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000270
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000271 520 stdcall SHAllocShared (long long long)
272 521 stdcall SHLockShared (long long)
273 522 stdcall SHUnlockShared (long)
274 523 stdcall SHFreeShared (long long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000275 524 stub RealDriveType@8
276 525 stub RealDriveTypeFlags@8
277
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000278 640 stdcall NTSHChangeNotifyRegister (long long long long long long)
279 641 stdcall NTSHChangeNotifyDeregister (long)
Alexandre Julliard642d3131998-07-12 19:29:36 +0000280
281 643 stub SHChangeNotifyReceive@16
282 644 stub SHChangeNotification_Lock@16
283 645 stub SHChangeNotification_Unlock@4
284 646 stub SHChangeRegistrationReceive@8
Juergen Schmied61013241998-10-16 15:40:20 +0000285 647 stub ReceiveAddToRecentDocs@8
Alexandre Julliard642d3131998-07-12 19:29:36 +0000286 648 stub SHWaitOp_Operate@8
287
Juergen Schmied6b266db2000-04-28 20:19:35 +0000288 650 stdcall PathIsSameRoot(ptr ptr)PathIsSameRootAW
Juergen Schmied37fe75b1999-07-10 11:54:17 +0000289
290# nt40/win98
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000291 651 stdcall ReadCabinetState (long long) # OldReadCabinetState
292 652 stdcall WriteCabinetState (long)
Juergen Schmied37fe75b1999-07-10 11:54:17 +0000293 653 stdcall PathProcessCommand (long long long long) PathProcessCommandAW
294
295# win98
Francois Gouget8a5de1c2000-12-14 19:25:13 +0000296 654 stdcall @(long long)shell32_654 # ReadCabinetState@8
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000297 660 stdcall FileIconInit(long)
298 680 stdcall IsUserAdmin()
Alexandre Julliard642d3131998-07-12 19:29:36 +0000299
Juergen Schmied0d18aad2000-06-01 23:25:44 +0000300# >= NT5
Francois Gouget8a5de1c2000-12-14 19:25:13 +0000301 714 stdcall @(ptr)SHELL32_714 # PathIsTemporaryW
Juergen Schmied0d18aad2000-06-01 23:25:44 +0000302
Alexandre Julliard642d3131998-07-12 19:29:36 +00003031217 stub FOOBAR1217 # no joke! This is the real name!!
Alexandre Julliard85ed45e1998-08-22 19:03:56 +0000304
Juergen Schmied13d74c52000-06-13 03:45:52 +0000305#
306# version 4.0 (win95)
307# _WIN32_IE >= 0x0200
308#
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000309@ stdcall CheckEscapesA(str long long ptr ptr long)
310@ stdcall CheckEscapesW(wstr long long ptr ptr long)
311@ stdcall CommandLineToArgvW(wstr ptr)
312@ stdcall Control_FillCache_RunDLL(long long long long)
Alexandre Julliard86f45312000-09-27 22:32:44 +0000313@ stub Control_FillCache_RunDLLA
314@ stub Control_FillCache_RunDLLW
Robert Shearmand1b77762002-12-13 02:17:54 +0000315@ stdcall Control_RunDLL(ptr ptr str long) Control_RunDLLA
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000316@ stdcall Control_RunDLLA(ptr ptr str long)
317@ stdcall Control_RunDLLW(ptr ptr wstr long)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000318@ stdcall DllInstall(long wstr)SHELL32_DllInstall
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000319@ stdcall DoEnvironmentSubstA(str str)
320@ stdcall DoEnvironmentSubstW(wstr wstr)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000321@ stub DragQueryFileAorW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000322@ stdcall DuplicateIcon(long long)
323@ stdcall ExtractAssociatedIconA(long ptr long)
324@ stdcall ExtractAssociatedIconExA(long str long long)
325@ stdcall ExtractAssociatedIconExW(long wstr long long)
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000326@ stub ExtractAssociatedIconW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000327@ stdcall ExtractIconA(long str long)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000328@ stdcall ExtractIconEx(ptr long ptr ptr long)ExtractIconExAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000329@ stdcall ExtractIconExA(str long ptr ptr long)
330@ stdcall ExtractIconExW(wstr long ptr ptr long)
331@ stdcall ExtractIconW(long wstr long)
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000332@ stub ExtractIconResInfoA
333@ stub ExtractIconResInfoW
334@ stub ExtractVersionResource16W
335@ stub FindExeDlgProc
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000336@ stdcall FindExecutableA(ptr ptr ptr)
337@ stdcall FindExecutableW(wstr wstr wstr)
338@ stdcall FreeIconList(long)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000339@ stub InternalExtractIconListA
340@ stub InternalExtractIconListW
341@ stub OpenAs_RunDLL
342@ stub OpenAs_RunDLLA
343@ stub OpenAs_RunDLLW
344@ stub PrintersGetCommand_RunDLL
345@ stub PrintersGetCommand_RunDLLA
346@ stub PrintersGetCommand_RunDLLW
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000347@ stub RealShellExecuteA
348@ stub RealShellExecuteExA
349@ stub RealShellExecuteExW
350@ stub RealShellExecuteW
351@ stub RegenerateUserEnvironment
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000352@ stdcall SHAddToRecentDocs (long ptr)
353@ stdcall SHAppBarMessage(long ptr)
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000354@ stdcall SHBrowseForFolder(ptr) SHBrowseForFolderA
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000355@ stdcall SHBrowseForFolderA(ptr)
356@ stdcall SHBrowseForFolderW(ptr)
357@ stdcall SHChangeNotify (long long ptr ptr)
358@ stdcall SHCreateDirectoryExA(long str ptr)
359@ stdcall SHCreateDirectoryExW(long wstr ptr)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000360@ stub ShellHookProc
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000361@ stub SHEmptyRecycleBinA@12
362@ stub SHEmptyRecycleBinW@12
Juergen Schmied13d74c52000-06-13 03:45:52 +0000363@ stdcall SHFileOperation(ptr)SHFileOperationAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000364@ stdcall SHFileOperationA(ptr)
365@ stdcall SHFileOperationW(ptr)
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000366@ stub SHFormatDrive@16
367@ stub SHFreeNameMappings@4
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000368@ stdcall SHGetDesktopFolder(ptr)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000369@ stdcall SHGetFileInfo(ptr long ptr long long)SHGetFileInfoAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000370@ stdcall SHGetFileInfoA(ptr long ptr long long)
371@ stdcall SHGetFileInfoW(ptr long ptr long long)
372@ stdcall SHGetInstanceExplorer(long)
373@ stdcall SHGetMalloc(ptr)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000374@ stub SHGetNewLinkInfo@20
375@ stdcall SHGetPathFromIDList(ptr ptr)SHGetPathFromIDListAW
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000376@ stdcall SHGetPathFromIDListA(ptr ptr)
377@ stdcall SHGetPathFromIDListW(ptr ptr)
378@ stdcall SHGetSettings(ptr long)
379@ stdcall SHGetSpecialFolderLocation(long long ptr)
380@ stdcall SHHelpShortcuts_RunDLL(long long long long)
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000381@ stub SHHelpShortcuts_RunDLLA@16
382@ stub SHHelpShortcuts_RunDLLW@16
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000383@ stdcall SHLoadInProc(long)
Alexandre Julliard7cae5582002-06-01 02:55:48 +0000384@ stub SHQueryRecycleBinA@8
385@ stub SHQueryRecycleBinW@8
386@ stub SHUpdateRecycleBinIcon@0
Juergen Schmied13d74c52000-06-13 03:45:52 +0000387@ stub WOWShellExecute@28
Juergen Schmied7c6cc491999-04-01 10:24:21 +0000388
Juergen Schmied13d74c52000-06-13 03:45:52 +0000389#
390# version 4.70 (IE3.0)
391# _WIN32_IE >= 0x0300
392#
Juergen Schmied7c6cc491999-04-01 10:24:21 +0000393
Juergen Schmied13d74c52000-06-13 03:45:52 +0000394#
395# version 4.71 (IE4.0)
396# _WIN32_IE >= 0x0400
397#
Andreas Mohr679226f2000-07-08 12:43:34 +0000398@ stdcall DllCanUnloadNow() SHELL32_DllCanUnloadNow
Juergen Schmied13d74c52000-06-13 03:45:52 +0000399@ stdcall DllGetVersion(ptr)SHELL32_DllGetVersion
400@ stub SHGetFreeDiskSpace
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000401@ stdcall SHGetSpecialFolderPathA(long ptr long long)
402@ stdcall SHGetSpecialFolderPathW(long ptr long long)
Juergen Schmied13d74c52000-06-13 03:45:52 +0000403#
404# version 4.72 (IE4.01)
405# _WIN32_IE >= 0x0401
406# no new exports
407#
Ian Schmidtcdff5431999-09-28 13:04:58 +0000408
Juergen Schmied13d74c52000-06-13 03:45:52 +0000409#
410# version 5.00 (Win2K)
411# _WIN32_IE >= 0x0500
412#
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000413@ stdcall SHGetFolderPathA(long long long long ptr)
414@ stdcall SHGetFolderPathW(long long long long ptr)
415@ stdcall SHGetFolderLocation(long long long long ptr)
Rolf Kalbermatter418ca6d2002-12-07 23:49:24 +0000416
417# version 6.0 (WinXP)
418# _WIN32_IE >= 0x600
Alexandre Julliard114a31a2003-03-20 03:53:12 +0000419@ stdcall SHDefExtractIconA(str long long ptr ptr long)
420@ stdcall SHDefExtractIconW(wstr long long ptr ptr long)