blob: 1829530000a452880edd0b15306dbd87ce220e59 [file] [log] [blame]
name shlwapi
type win32
# ordinal exports
1 stub @
2 stub @
3 stub @
4 stub @
5 stub @
6 stub @
7 stub @
8 stub @
9 stub @
10 stub @
11 stub @
12 stub @
13 stub @
14 stub @
15 stub @
16 stub @
17 stub @
18 stub @
19 stub @
20 stub @
21 stub @
22 stub @
23 stub @
24 stub @
25 stub @
26 stub @
27 stub @
28 stub @
29 stub @
30 stub @
31 stub @
32 stub @
33 stub @
34 stub @
35 stub @
36 stub @
37 stub @
38 stub @
39 stub @
40 stub @
41 stub @
42 stub @
43 stub @
44 stub @
45 stub @
46 stub @
47 stub @
48 stub @
49 stub @
50 stub @
51 stub @
52 stub @
53 stub @
54 stub @
55 stub @
56 stub @
57 stub @
58 stub @
59 stub @
60 stub @
61 stub @
62 stub @
63 stub @
64 stub @
65 stub @
66 stub @
67 stub @
68 stub @
69 stub @
70 stub @
71 stub @
72 stub @
73 stub @
74 stub @
75 stub @
76 stub @
77 stub @
78 stub @
79 stub @
80 stub @
81 stub @
82 stub @
83 stub @
84 stub @
85 stub @
86 stub @
87 stub @
88 stub @
89 stub @
90 stub @
91 stub @
92 stub @
93 stub @
94 stub @
95 stub @
96 stub @
97 stub @
98 stub @
99 stub @
100 stub @
101 stub @
102 stub @
103 stub @
104 stub @
105 stub @
106 stub @
107 stub @
108 stub @
109 stub @
110 stub @
111 stub @
112 stub @
113 stub @
114 stub @
115 stub @
116 stub @
117 stub @
118 stub @
119 stub @
120 stub @
121 stub @
122 stub @
123 stub @
124 stub @
125 stub @
126 stub @
127 stub @
128 stub @
129 stub @
130 stub @
131 stub @
132 stub @
133 stub @
134 stub @
135 stub @
136 stub @
137 stub @
138 stub @
139 stub @
140 stub @
141 stub @
142 stub @
143 stub @
144 stub @
145 stub @
146 stub @
147 stub @
148 stub @
149 stub @
150 stub @
151 stub @
152 stub @
153 stub @
154 stub @
155 stub @
156 stub @
157 stub @
158 stub @
159 stub @
160 stub @
161 stub @
@ stub ChrCmpIA
@ stub ChrCmpIW
@ stub DllGetVersion
@ stub GetMenuPosFromID
@ stub HashData
@ stub IntlStrEqWorkerA
@ stub IntlStrEqWorkerW
@ stdcall PathAddBackslashA (ptr) PathAddBackslashA
@ stdcall PathAddBackslashW (ptr) PathAddBackslashW
@ stub PathAddExtensionA
@ stub PathAddExtensionW
@ stdcall PathAppendA (str str) PathAppendA
@ stub PathAppendW
@ stdcall PathBuildRootA (ptr long) PathBuildRootA
@ stub PathBuildRootW
@ stub PathCanonicalizeA
@ stub PathCanonicalizeW
@ stdcall PathCombineA (ptr ptr ptr) PathCombineA
@ stdcall PathCombineW (ptr ptr ptr) PathCombineW
@ stub PathCommonPrefixA
@ stub PathCommonPrefixW
@ stub PathCompactPathA
@ stub PathCompactPathExA
@ stub PathCompactPathExW
@ stub PathCompactPathW
@ stub PathCreateFromUrlA
@ stub PathCreateFromUrlW
@ stdcall PathFileExistsA (str) PathFileExistsA
@ stub PathFileExistsW
@ stdcall PathFindExtensionA (ptr) PathFindExtensionA
@ stdcall PathFindExtensionW (ptr) PathFindExtensionW
@ stdcall PathFindFileNameA (ptr) PathFindFilenameA
@ stdcall PathFindFileNameW (ptr) PathFindFilenameW
@ stub PathFindNextComponentA
@ stub PathFindNextComponentW
@ stdcall PathFindOnPathA (ptr ptr) PathFindOnPathA
@ stdcall PathFindOnPathW (ptr ptr) PathFindOnPathW
@ stdcall PathGetArgsA (str) PathGetArgsA
@ stdcall PathGetArgsW (str) PathGetArgsW
@ stub PathGetCharTypeA
@ stub PathGetCharTypeW
@ stdcall PathGetDriveNumberA (str) PathGetDriveNumber
@ stub PathGetDriveNumberW #(str) PathGetDriveNumber
@ stub PathIsContentTypeA
@ stub PathIsContentTypeW
@ stdcall PathIsDirectoryA(str) PathIsDirectoryA
@ stdcall PathIsDirectoryW(wstr) PathIsDirectoryW
@ stub PathIsFileSpecA
@ stub PathIsFileSpecW
@ stub PathIsPrefixA
@ stub PathIsPrefixW
@ stdcall PathIsRelativeA (ptr) PathIsRelativeA
@ stdcall PathIsRelativeW (ptr) PathIsRelativeW
@ stdcall PathIsRootA(str) PathIsRootA
@ stdcall PathIsRootW(wstr) PathIsRootW
@ stub PathIsSameRootA
@ stub PathIsSameRootW
@ stub PathIsSystemFolderA
@ stub PathIsSystemFolderW
@ stdcall PathIsUNCA (ptr) PathIsUNCA
@ stub PathIsUNCServerA
@ stub PathIsUNCServerShareA
@ stub PathIsUNCServerShareW
@ stub PathIsUNCServerW
@ stdcall PathIsUNCW(wstr) PathIsUNCW
@ stdcall PathIsURLA(str) PathIsURLA
@ stub PathIsURLW
@ stub PathMakePrettyA
@ stub PathMakePrettyW
@ stub PathMakeSystemFolderA
@ stub PathMakeSystemFolderW
@ stdcall PathMatchSpecA (str str) PathMatchSpecA
@ stdcall PathMatchSpecW (str str) PathMatchSpecW
@ stub PathParseIconLocationA
@ stub PathParseIconLocationW
@ stdcall PathQuoteSpacesA (ptr) PathQuoteSpacesW
@ stdcall PathQuoteSpacesW (ptr) PathQuoteSpacesW
@ stub PathRelativePathToA
@ stub PathRelativePathToW
@ stub PathRemoveArgsA
@ stub PathRemoveArgsW
@ stdcall PathRemoveBackslashA (ptr) PathRemoveBackslashA
@ stdcall PathRemoveBackslashW (ptr) PathRemoveBackslashW
@ stdcall PathRemoveBlanksA(str) PathRemoveBlanksA
@ stdcall PathRemoveBlanksW(wstr) PathRemoveBlanksW
@ stub PathRemoveExtensionA
@ stub PathRemoveExtensionW
@ stdcall PathRemoveFileSpecA (str) PathRemoveFileSpecA
@ stub PathRemoveFileSpecW
@ stub PathRenameExtensionA
@ stub PathRenameExtensionW
@ stub PathSearchAndQualifyA
@ stub PathSearchAndQualifyW
@ stdcall PathSetDlgItemPathA (long long ptr) PathSetDlgItemPathA
@ stdcall PathSetDlgItemPathW (long long ptr) PathSetDlgItemPathW
@ stub PathSkipRootA
@ stub PathSkipRootW
@ stub PathStripPathA
@ stub PathStripPathW
@ stub PathStripToRootA
@ stub PathStripToRootW
@ stub PathUnmakeSystemFolderA
@ stub PathUnmakeSystemFolderW
@ stdcall PathUnquoteSpacesA (str) PathUnquoteSpacesA
@ stdcall PathUnquoteSpacesW (str) PathUnquoteSpacesW
@ stub SHCreateShellPalette
@ stub SHDeleteEmptyKeyA
@ stub SHDeleteEmptyKeyW
@ stdcall SHDeleteKeyA(long str)SHRegDeleteKeyA
@ stdcall SHDeleteKeyW(long str)SHRegDeleteKeyW
@ stub SHDeleteOrphanKeyA
@ stub SHDeleteOrphanKeyW
@ stub SHDeleteValueA
@ stub SHDeleteValueW
@ stub SHEnumKeyExA
@ stub SHEnumKeyExW
@ stub SHEnumValueA
@ stub SHEnumValueW
@ stub SHGetInverseCMAP
@ stdcall SHGetValueA ( long ptr ptr ptr ptr ptr ) SHGetValueA
@ stdcall SHGetValueW ( long ptr ptr ptr ptr ptr ) SHGetValueW
@ stub SHIsLowMemoryMachine
@ stub SHOpenRegStreamA
@ stub SHOpenRegStreamW
@ stub SHQueryInfoKeyA
@ stub SHQueryInfoKeyW
@ stub SHQueryValueExA
@ stub SHQueryValueExW
@ stub SHRegCloseUSKey
@ stub SHRegCreateUSKeyA
@ stub SHRegCreateUSKeyW
@ stub SHRegDeleteEmptyUSKeyA
@ stub SHRegDeleteEmptyUSKeyW
@ stub SHRegDeleteUSValueA
@ stub SHRegDeleteUSValueW
@ stub SHRegEnumUSKeyA
@ stub SHRegEnumUSKeyW
@ stub SHRegEnumUSValueA
@ stub SHRegEnumUSValueW
@ stub SHRegGetBoolUSValueA
@ stub SHRegGetBoolUSValueW
@ stdcall SHRegGetUSValueA ( ptr ptr ptr ptr ptr long ptr long ) SHRegGetUSValueA
@ stdcall SHRegGetUSValueW ( ptr ptr ptr ptr ptr long ptr long ) SHRegGetUSValueW
@ stub SHRegOpenUSKeyA
@ stub SHRegOpenUSKeyW
@ stub SHRegQueryInfoUSKeyA
@ stub SHRegQueryInfoUSKeyW
@ stub SHRegQueryUSValueA
@ stub SHRegQueryUSValueW
@ stub SHRegSetUSValueA
@ stub SHRegSetUSValueW
@ stub SHRegWriteUSValueA
@ stub SHRegWriteUSValueW
@ stub SHSetValueA
@ stub SHSetValueW
@ stub StrCSpnA
@ stub StrCSpnIA
@ stub StrCSpnIW
@ stub StrCSpnW
@ stub StrCatW
@ stub StrChrA
@ stub StrChrIA
@ stub StrChrIW
@ stdcall StrChrW (ptr ptr) StrChrW
@ stub StrCmpIW
@ stub StrCmpNA
@ stub StrCmpNIA
@ stdcall StrCmpNIW (wstr wstr long) StrCmpNIW
@ stub StrCmpNW
@ stub StrCmpW
@ stub StrCpyNW
@ stub StrCpyW
@ stub StrDupA
@ stub StrDupW
@ stdcall StrFormatByteSizeA(long str long) StrFormatByteSizeA
@ stdcall StrFormatByteSizeW(long wstr long) StrFormatByteSizeW
@ stub StrFromTimeIntervalA
@ stub StrFromTimeIntervalW
@ stub StrIsIntlEqualA
@ stub StrIsIntlEqualW
@ stub StrNCatA
@ stub StrNCatW
@ stub StrPBrkA
@ stub StrPBrkW
@ stdcall StrRChrA (str str long) lstrrchr
@ stub StrRChrIA
@ stub StrRChrIW
@ stdcall StrRChrW (wstr wstr long) lstrrchrw
@ stub StrRStrIA
@ stub StrRStrIW
@ stub StrSpnA
@ stub StrSpnW
@ stub StrStrA
@ stub StrStrIA
@ stub StrStrIW
@ stub StrStrW
@ stub StrToIntA
@ stub StrToIntExA
@ stub StrToIntExW
@ stub StrToIntW
@ stub StrTrimA
@ stub StrTrimW
@ stub UrlApplySchemeA
@ stub UrlApplySchemeW
@ stub UrlCanonicalizeA
@ stub UrlCanonicalizeW
@ stub UrlCombineA
@ stub UrlCombineW
@ stub UrlCompareA
@ stub UrlCompareW
@ stub UrlCreateFromPathA
@ stub UrlCreateFromPathW
@ stub UrlEscapeA
@ stub UrlEscapeW
@ stub UrlGetLocationA
@ stub UrlGetLocationW
@ stub UrlGetPartA
@ stub UrlGetPartW
@ stub UrlHashA
@ stub UrlHashW
@ stub UrlIsA
@ stub UrlIsNoHistoryA
@ stub UrlIsNoHistoryW
@ stub UrlIsOpaqueA
@ stub UrlIsOpaqueW
@ stub UrlIsW
@ stub UrlUnescapeA
@ stub UrlUnescapeW
# exported in later versions
@ stdcall StrRetToBufA (ptr ptr ptr long) StrRetToBufA
@ stdcall StrRetToBufW (ptr ptr ptr long) StrRetToBufW
#@ stdcall StrRetToStrA (ptr ptr ptr) StrRetToStrA
#@ stdcall StrRetToStrW (ptr ptr ptr) StrRetToStrW